华南中天论坛

 找回密码
 立即注册

QQ登录

只需一步,快速开始

搜索
热搜: 活动 交友 discuz
华南中天论坛 门户 网络技术 大数据 查看内容

提示:Cannot resolve plugin org.apache.maven.plugins:maven-site-plugin:3.8.2的解决办法

2020-1-18 22:18| 发布者: 有法可依| 查看: 221| 评论: 0

摘要: 本文针对《Spring Boot 实战派》的读者。 今天有读者反映新建项目后,提示如下错误: Cannot resolve plugin org.apa

本文针对《Spring Boot 实战派》的读者。
今天有读者反映新建项目后,提示如下错误:

Cannot resolve plugin org.apache.maven.plugins:maven-site-plugin:3.8.2

该错误的意思是:不能解析maven的maven-site-plugin:3.8.2。为了便于读者理解和解决,本文针对这个错误进行简单讲解。
该错误的产生的原因和解决办法有以下几种:

1. 下载过程中出现了网络或文件错误

这是最常见的错误,特别是没有配置Maven国内镜像的情况下,会有极大概率遇到这种情况。
解决办法:针对这种情况可以执行CLEAN命令,然后重新下载maven依赖,或者删除依赖文件夹后重新下载。

2. IDEA的Maven环境配置错误

这种情况多半是IDEA配置的Maven依赖和POM文件添加的依赖不一致导致的。
解决办法:可以在plugin元素中去掉版本(version):如:

<build>
	<plugins>
		<plugin>
			<groupId>org.springframework.bootgroupId>
			<artifactId>spring-boot-maven-pluginartifactId>
			~~<version>3.6.3version>~~ 
		plugin>
	plugins>
build>

这种错误一般是在新建项目时才会产生,所以,如果上面2种办法都解决不了,则可以重新新建项目来解决。

值得推敲的人生 发布了12 篇原创文章 · 获赞 7 · 访问量 1254 私信 关注
来源:https://blog.csdn.net/u013840066/article/details/104024287
免责声明:如果侵犯了您的权益,请联系站长,我们会及时删除侵权内容,谢谢合作!

鲜花

握手

雷人

路过

鸡蛋

最新评论

QQ|Archiver|手机版|小黑屋|南华中天社区 ( 粤ICP备11019662号 )

GMT+8, 2020-10-21 23:46 , Processed in 0.033103 second(s), 15 queries .

Powered by Discuz! X3.4

Copyright © 2001-2020, Tencent Cloud.

返回顶部